Forum Home | Heirloom

Topic

BlondQlTr
By: BlondQlTr
Posts: 1
Help w/ disengaging lock stitch on faceplate
I made the mistake of engaging my lockstitch to secure a miter while binding. I was trying to secure the binding w/ a decorative stitch. The machine will NOT move on with the pattern and it just keeps putting thread in that one spot. I tried powering the machine off and back on but still no luck. The manual is unhelpful, as is the My 15000 App. Am I MISSING something?
Replies

  1. RE: Help w/ disengaging lock stitch on faceplate

    All decorative stitches start with a "lock stitch" and when you engage the lockstitch close to the end, the machine finishes the pattern and locks. It should continue you the same stitch once you thread cut and start in a different place. I'm assuming that you've tried this, but did you try to use a different stitch - go to your "Utilities" screen and pick just a regular straight stitch - will it see that without messing up. Also check to see that the feed dogs are raised - they shouldn't have changed but perhaps they did. If nothing you do without stressful effort works, you'll need to take your machine in to your dealer and see what got messed up for no good reason when you tried your project.

    I know what frustration these machines can be, I just got mine back from my technician after the threader jammed and then I couldn't even sew a stitch. It turned out that the threader has a safety mechanism that came out of a grove and the needle bar couldn't raise up as this gizmo was suppose to be in it - not above it - something that I wouldn't be able to fix at home. These guys are just getting to big and heavy to leave the sewing room.

    Cheryl
    Posted: Aug 29 2019 By: CherylAnn
DEALERS
The TWO Closest Dealers to you are:
11925 SW FREEWAY SUITE11, STAFFORD TX, 77477
281-491-0016
829 S. MASON ROAD , KATY TX, 77450
281.398.0670
WWW.QUILTNSEW.COM
Find Additional Dealers